KB0032 – SM12 lock errors

Customers are reporting issues with lock errors when users attempt to approve workflow requests.

Applies to : Promenta versions 1.6 SP36 to SP38-1

Symptoms

Your approvers may see an error like the screenshot below. It may even show their own user id.

 

Cause

User opens a request with an attachment , opens the attachment and then closes the tab or browser. This leaves the SAP session still in SAP and so any locks held by the session are also kept.

Fix

Apply Promenta version 1.6 SP38-2

Work-around

If you are sure that all browsers are closed – then the lock can be safely deleted using SM12 or the Promenta tools (if authorised). Users can then re-open and approve.

To prevent it happening : If the user opens the attachments and then clicks any other Promenat button (eg the “next” button, “simulate” button etc) then on close the session will be cleared. Make you users aware that they should not close the tab without first clicking on a button.

 

 

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